lein 2.8.3 使用 nrepl 不能用 cider 连接?


#1

lein 使用 2.8.3, 其用户配置中(~/.lein/profiles.clj) 添加了 cider/cider-nrepl, emacs 中的cider 也是最新的版本:

➜ tttt lein version
Warning: implicit middleware found: cider-nrepl.plugin/middleware
Please declare all middleware in :middleware as implicit loading is deprecated.
Leiningen 2.8.3 on Java 11.0.1 Java HotSpot™ 64-Bit Server VM

➜ tttt cat ~/.lein/profiles.clj
{:user
{
:plugins [[cider/cider-nrepl “0.20.0”]]}}

但是在 emacs 中连接一个开启 nrepl 的项目 cider-connect 却报警告,而且不能工作(不能eval,等):

;; ======================================================================
WARNING: CIDER requires cider-nrepl to be fully functional. Many things will not work without it!
More information.
user>


#2

找到问题了,是自己使用 cider-nrepl 启动nrepl服务时,handler 参数传递的有问题。目前已经解决